说明

SIMATIC Panels 常见问题集 >
说明

内容：本文档包含 WinCC Flexible Smart V3 软件及基于 WinCC Flexible Smart V3 的面板的常见问题。

版本：V1.0

Copyright 2003-2011 Siemens


SmartLine-IE V3

SIMATIC Panels 常见问题集 >
SmartLine-IE V3

SmartLine-IE V3 版本的常见问题。


SmartLine-IE V3 面板介绍

SIMATIC Panels 常见问题集 > SmartLine-IE V3 >
SmartLine-IE V3 面板介绍

该章节包括以下主题的信息:

.Smart V3 和 Smart V2 版本的区别

.Smart V3 面板选型

.面板使用环境

.相关认证

.组态软件


Smart V3 和 Smart V2 版本的区别

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > SmartLine-IE V3 面板介绍 >
Smart V3 和 Smart V2 版本的区别

Smart 面板分为第一代产品(V1) SmartLine（无以太网接口，包括 Smart700 和 Smart1000 两款）和第二代产品(V2) SmartLine-IE（带以太网接口，包括 Smart700-IE 和 Smart1000-IE 两款），及第三代产品(V3) SmartLine V3(包括 Smart700-IE V3 和 Smart1000-IE V3两款)目前在售的为 SmartLine-IE V3 产品。

SmartLine-IE V3 相比 V2 的 SmartLine 具有以下优点：

>宽屏7寸、10寸，支持横向和竖向安装，Smrat 1000-IE V3 分辨率由 V2 的 800*480 增至 1024*600。

>极大的提高了触摸的灵敏度。

>集成的以太网口可与 S7 200系列PLC及LOGO!进行通讯(最多可连接4台)。

>新增了 USB 2.0 host接口，可连接鼠标、Hub以及 USB 存储器（可用作数据的记录及触摸屏的备份恢复）。

>新增了硬件时钟功能（缓冲时间长达6周）。

>新增了数据记录及报警记录功能（仅记录）。

SmartLine-IE V3 面板操作手册下载地址：
http://www.industry.siemens.com.cn/automation/cn/zh/human-machine-interface/operatorinterfaces/smart-line/Documents/productmanual.pdf


Smart V3 面板选型

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > SmartLine-IE V3 面板介绍 >
Smart V3 面板选型

SmartLine-IE V3 订货数据：

SmartLine-IE V3 宣传页:
 http://www.industry.siemens.com.cn/automation/cn/zh/human-machine-interface/operatorinterfaces/smart-line/Documents/SMART-LINE-V3-brochure.pdf


面板使用环境

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > SmartLine-IE V3 面板介绍 >
面板使用环境

面板的使用环境对温度、湿度、振动等有相应的要求。

比如面把垂直安装时要求温度0到50°C，而安装倾斜角为35°（最大倾斜角为 35°）时要求温度最大为40°C。

关于其它的环境要求请参考手册中 8.2~8.4 章节的描述，手册下载地址：
http://www.industry.siemens.com.cn/automation/cn/zh/human-machine-interface/operatorinterfaces/smart-line/Documents/productmanual.pdf


相关认证

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > SmartLine-IE V3 面板介绍 >
相关认证

Smart IE V3 CE 及 RoHS证书下载地址：
http://www.industry.siemens.com.cn/automation/cn/zh/human-machine-interface/operatorinterfaces/smart-line/Documents/CE-and-RoHS-certification-for-SIMATIC_HMI_SMART_IE_V3.pdf

另外，面板不需要 3C 认证，可以参考：
http://support.automation.siemens.com/WW/view/en/26621079


组态软件

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > SmartLine-IE V3 面板介绍 >
组态软件

第一代 SmartLine（不带以太网口）需要使用 WinCC flexible 2008 Sp2 China 以上版本来组态。

说明：WinCC flexible 2008 Sp2 China 需要安装 SmartLine 硬件补丁包（HSP），WinCC flexible 2008 Sp3 China 、WinCC flexible 2008 Sp4 China 可以直接组态第一代 SmartLine。

第二代 SmartLine-IE 只能使用 WinCC flexible 2008 Sp4 China 来组态。

第三代 SmartLine-IE V3 只能使用 WinCC flexible Smart V3 软件来组态。WinCC flexible Smart V3 软件中包含 V1 及 V2 版本的 SmartLine 触摸屏。

软件下载
Siemens 官方网站提供 WinCC flexible Smart V3 软件下载的地址：
 http://www.industry.siemens.com.cn/automation/cn/zh/human-machine-interface/operatorinterfaces/smart-line/Pages/software.aspx

打开 WinCC flexible Smart V3 软件下在地址链接后如下图：

注意：
1.WinCC flexible Smart V3 软件可以与 WinCCFlexible 2008 SP4 一同安装 ，但只支持 Win7 SP1 的相应版本系统而不再支持 XP 系统 。如果以安装包形式安装，那么安装包的路径中不可包含中文。
2.WinCC flexible Smart V3 软件仅包含 Smart Line 系列触摸屏 （V1、V2、V3）。
3.ProSave 软件不再在 WinCC flexible Smart V3 软件中提供，需单独从 Prosave 软件链接中下载 （下载前提：已注册全球技术资源库帐号，并通过下载程序许可的认证）。
4.在自动安装时安装 SQL Server 后会要求重启计算机，如果由于计算机异常遇到反复重启的情况，可尝试进入注册表编辑器（方法：开始菜单-运行-输入 regedit 后回车），
然后在如下路径“HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\”删除注册表值“PendingFileRenameOperations”。如果问题依旧，请更换系统并
重新安装软件。


项目下载

SIMATIC Panels 常见问题集 > SmartLine-IE V3 >
项目下载

该章节包括以下主题的信息:

.项目下载

.OS更新

.Pack & Go

.项目备份及恢复


项目下载

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > 项目下载 >
项目下载

Smartline - IE V3 项目下载：

注意：
 1.Smartline - IE V3 不再支持使用 S7 200 的编程电缆 PC/PPI电缆（6ES7 901-3CB30-0XA0）或 USB/PPI电缆（6ES7 901-3DB30-0XA0）进行下载，仅可通过以太网方式下载程序。
2.下载前必须确认计算机上未安装或使用过与 WinCC Flexible Smart V3 相冲突的软件（常见软件包括：卡巴斯基，金山毒霸，瑞星等杀毒软件及第三方优化工具或防火墙），如果安装或使用过与 WinCC Flexible Smart V3 相冲突的软件，需卸载该软件并重新安装 WinCC Flexible Smart V3 软件。
3.Windows 系统登录的用户的用户名只可使用英文或数字并以英文开头，不可包含特殊字符或中文字符，否则在传送项目时会提示兼容性检查失败 。

下载设置步骤：

1.首先进行触摸屏端的设置，触摸屏上电后点击加载菜单中的“Control Panel” 选项。

2.双击 “Ethernet” 选项。

3.将触摸屏IP地址与计算机本地地址设置在同一网段，此例中作为下载使用的计算机IP地址为 192.168.0.xxx 网段，所
以此处将屏的地址设置为 192.168.0.126。请注意，子网掩码（Subnet Mask）设为 255.255.255.0即可，默认网关
（Def.Gateway）无需设置。设置完成后点击右上角 “OK” 按钮退出该界面。

4.第3步中点 “OK” 后会回到 “Control Panel” 界面，然后双击 “Transfer” 选项。

5.选中 “Enable Channel” 及 “Remote Control” 选项，如下图，然后点击右上角 “OK” 选项确认并退出该界面。

6.返回至触摸屏上电加载界面，并点击菜单中的 “Transfer” 按钮。

7.将交叉网线接入触摸屏端的RJ45接口，然后点击 “Transfer” 按钮即会显示以下界面，看到 “connecting to host...” 后，
屏端的设置结束。

直连线与交叉线线序示意图：

8.点击计算机的 “开始菜单--运行”（或同时按下计算机的 “Windows键+R键”），在弹出的 “运行” 窗口中输入 ncpa.cpl
并点击确定。

9.在弹出的 “网络连接” 窗口中找到本地连接，并在该连接上点击右键后点击属性，如下图。

10.在弹出的 “本地连接属性”对话框中选择 “Internet Protocol Version4（TCP/IPv4）”选项后，点击属性

11.确定计算机IP地址与触摸屏在同一网段，本例中使用 192.168.0.xxx
网段，所以 192.168.0.233 与触摸屏在同一网段。注意子网掩码
（Subnet mask）设置为 255.255.255.0，默认网关（Default gateway）
不需要设置。

12.在确认了计算机地址与触摸屏地址在同一网段后，使用 DOS的 Ping
命令确定计算机与触摸屏的物理链路是否正常。点击计算机的 “开始菜单
--运行”或点击键盘上的 “Windows键+R键” ，在弹出的 “运行” 窗口中输入
cmd 然后点击确定。

13.在弹出的 MS- DOS 窗口中输入? ping 触摸屏IP地址，看到丢失（lost）
后的数字为 0 时，说明物理链路正常，如果丢失（lost）后的数字不等于0，
那么需要重新检查两台设备的IP地址是否在同一网段，并且更换其他网线重
新执行ping命令直到丢失（lost）后的数值为0时才可进行下一步。

14.确认物理链路正常后，打开计算机的控制面板，将右上角的查看方式改为大图标，然后找到 “设置PG/PC 接口”或
“Set PG/PC Interface（32-bit）”并双击该图标。

15.在弹出的窗口中上方的应用程序访问点的下拉菜单中选择 “S7ONLINE（STEP7）”，并在下方的接口参数分配（左
下方滚动条）中选择 “计算机本地连接网卡名字.TCP/IP.1”的选项，注意不要选择 “计算机本地连接网卡名字.TCP/IP.Auto”
的选项。网卡名称可在第10步中的连接属性中察看。此例中为 “Inter（R）82579LM Gigabit”，选好后，点击确定退出。

16.再次确认触摸屏处于第7部的状态后，打开 WinCC Flexible Smart V3 软件并打开 Smartline-IE V3 项目，点击菜单中 “项目--传送--传输”

17.在弹出的窗口中的 “计算机名或IP地址” 处，填写触摸屏IP地址，本例中为 192.168.0.126，然后点击传送即可。


OS更新

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > 项目下载 >
OS更新

OS更新：

1.打开 Prosave 软件（软件位置：计算机开始菜单-所有程序-Siemens Automation-SIMATIC-ProSave），
将设备类型设置成您的 SmartLine IE V3 的类型，IP地址处填写您给触摸屏设置的IP地址，本例中为
192.168.0.126。

2.将计算机与触摸屏通过以太网网线连接，并将触摸屏设置为传送模式，如下图

3.点击 “OS” 更新选项卡，并点击 “更新OS”按钮。


Pack & Go

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > 项目下载 >
Pack & Go

Pack & Go 可以把 Wincc flexible Smart V3 项目打包传送到现场，现场的计算机可以在没有安装 Wincc flexible 的情况下把项目传送的面板中。

参考：

如何在 WinCC flexible 中使用 Pack & Go 创建间接传送？
http://support.automation.siemens.com/CN/view/zh/36305011

问题：在 Pack & Go 生成的文件夹，打开 StartTransfer.bat 后传送，有下图的错误提示：

原因：这是由于 Pack & Go 文件所处的路径存在中文字符。

例如使用如下路径即会出错：
“G:\新建文件夹\testaa\Pack&Go.Smart 1000 IE V3”。
将路径改为：
“G:\testaa\Pack&Go.Smart 1000 IE V3” 即可。

注意：
1.Pack & Go 不能做 OS 更新。
2.Pack & Go 文件不要放在包括中文字符的路径下。


项目备份及恢复

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > 项目下载 >
项目备份及恢复

“回传”与“备份”的区别：

> WinCC flexible 里“回传”是指把存贮在面板的外存储介质（比如 MMC 卡、SD 卡）里的压缩的原始项目文件回传到计算机里。该文件可以被 WinCC flexible 打开、查看和编辑，也可以用作不同面板间的移植。

> WinCC flexible 里“备份”是指把面板内存里的运行文件上传到计算机里。该文件只能原封不动地恢复到同型号的面板里，不能被打开、查看和编辑。

Smart Panels 均不支持“回传”功能，只支持“备份”“恢复”功能。

使用 ProSave 进行面板的备份和恢复：

1.打开 Prosave 软件（软件位置：计算机开始菜单-所有程序-Siemens Automation-SIMATIC-ProSave），
将设备类型设置成您的 SmartLine IE V3 的类型，IP地址处填写您给触摸屏设置的IP地址，本例中为
192.168.0.126。

2.将计算机与触摸屏使用网线连接后将触摸屏设置为传送模式。

备份：
切换到Prosave软件的“备份”栏，选择备份内容和备份文件的存储路径，然后点击“开始备份”进行备份。

恢复：
切换到Prosave软件的“恢复”栏，选择已经备份好的文件路径及文件，然后点击“开始恢复”进行恢复。

使用USB记忆棒进行备份及恢复：

Smartline-IE V3 支持 USB2.0 设备，格式需使用 NTFS 或 FAT32。可通过 USB 2.0记忆棒对
屏进行备份和恢复或存储报警记录或数据记录。

1.将USB2.0 USB记忆棒接入触摸屏的 USB 接口并给触摸屏上电。点击加载菜单中的“Control Panel”按钮。

2.双击“Service & Commissioning”选项。

使用USB备份：
选择选项卡中的 “Backup”选项，并在 “Choose Backup Type”中选择需要备份的类型，此例选择
“Complete backup”-即完整备份。然后点击 “Next” 按钮进入下一步。

选择已接入的 USB2.0 记忆棒，然后点击下一步。
如果已经接入 USB 记忆棒但无法在该列表中看到，请确认以下几点：
1）USB记忆棒为USB 2.0并符合USB设备支持中的相应设备
2）格式为 NTFS 或 FAT32
3）大小不可超过32GB
4）如果以上均符合，尝试更换USB记忆棒。

点击“Start”按钮开始备份。

使用USB进行恢复：

选择 “Restore” 选项，并点击 “Next” 按钮。

选择已接入的 USB记忆棒，并点击 “Next”。

点击 “Start” 按钮开始恢复。


PLC通讯

SIMATIC Panels 常见问题集 > SmartLine-IE V3 >
PLC通讯

该章节包括以下主题的信息:

.支持的 PLC

.Smart V3 连接 PLC 的数量的变化

.与PLC通讯V2


支持的 PLC

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > PLC通讯 >
支持的 PLC

第三代产品 SmartLine-IE V3：
串口：S7-200、S7-200 CN、Smart200、OMRON CP1 系列、三菱 FX 系列、Modbus RTU、台达
以太网：S7-200（CP243-1）、Smart200、LOGO!
注意：串口和以太网口只能使用一个 ，否则编译通不过。

SmartLine-IE V3 通讯的详细信息可参考手册中 8.9 章节的描述，手册下载地址：
http://www.industry.siemens.com.cn/automation/cn/zh/human-machine-interface/operatorinterfaces/smart-line/Documents/productmanual.pdf


Smart V3 连接 PLC 的数量的变化

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > PLC通讯 >
Smart V3 连接 PLC 的数量的变化

SmartLine-IE V3 的变化：
通过串口最多可连接4台 S7-200 或 S7-200 CN 或 Smart200 ，通过以太网可以连接4 台 S7-200 或 S7-200 CN 或 Smart200 或 LOGO! ，但是串口和以太网不能同时使用（编译通不过）。


与PLC通讯V2

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > PLC通讯 >
与PLC通讯V2

SmartLine-IE V3 版本与PLC通讯组态及配置与 SmartLine-IE V2 版本一致，以下为 V2 版本面板问题集信息。

该章节包括以下主题的信息:

.与第三方 PLC 通讯

.显示三菱 PLC 中的负数

.OMRON PLC 能读不能写

.通过 EM277 连接 S7-200

.通过 CP243-1 连接 S7-200

.面板和 Micro/Win 同时连接 S7-200

.S7-200 字符串

.和 LOGO! 通信

.画面刷新慢

.判断通信是否中断

.通讯优化


与第三方 PLC 通讯

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > PLC通讯 > 与PLC通讯V2 >
与第三方 PLC 通讯

该章节包括以下主题的信息:

.三菱 FX 系列

.OMRON CP1 系列

.Modbus RTU

.台达


三菱 FX 系列

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > PLC通讯 > 与PLC通讯V2 > 与第三方 PLC 通讯 >
三菱 FX 系列

Smart Panels 连接 三菱 FX PLC：

1、面板拨码（SmartLine-IE V2 及 V3 不需要做此操作）：

2、连接电缆：

三菱 FX PLC 编程口管角定义如下：

3、通讯设置：

PLC 不需要做设置。

WinCC flexible 软件中创建连接，设置如下：


OMRON CP1 系列

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > PLC通讯 > 与PLC通讯V2 > 与第三方 PLC 通讯 >
OMRON CP1 系列

Smart Panels 连接 OMRON PLC：

1、面板拨码（SmartLine-IE 不需要做此操作）：

2、OMRON PLC 需要安装选件板

3、通讯电缆

4、通讯设置：

项目中连接参数要和 PLC 的参数一一对应

注意：只有PLC处于“监视”状态才可以进行写操作


Modbus RTU

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > PLC通讯 > 与PLC通讯V2 > 与第三方 PLC 通讯 >
Modbus RTU

问题：WinCC flexible 中的 Modbus RTU 驱动只是针对 Modicon PLC 的，那么支持 Modbus RTU 协议的第三方设备（仪表）能否和 Smart Panels 通讯？

解答：

WinCC flexible 中的 Modbus RTU 驱动确实只是针对施耐德 PLC 的，但是只要是第三方设备（仪表）的协议和 Modicon PLC 相同，那么就可以使用这个驱动来通讯。


台达

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > PLC通讯 > 与PLC通讯V2 > 与第三方 PLC 通讯 >
台达

Smart Panels 使用 Modbus RTU 驱动连接台达 PLC ，在“CPU 类型”中选择 “Delta”设备（只有 Smartline-IE 支持）：


显示三菱 PLC 中的负数

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > PLC通讯 > 与PLC通讯V2 >
显示三菱 PLC 中的负数

问题：三菱 PLC 中的负数如何在 Smart Panels 上显示？

解答：分两种情况

1、FX2N、FX3U 支持实数类型，可以在 PLC 使用 FLT 指令把负数转成实数显示。

2、其它不支持实数的 FX PLC，可以通过如下方法实现（以 D100 为例）：

（1）PLC 中编程，把负数 D100 转成两部分：绝对值 D102 和符号位 M215：

（2）WinCC flexible 中创建变量对应“绝对值”和“符号位”：

（3）创建文本列表用来显示符号“+/-”：

（4）在 WinCC flexible 画面中分别显示“绝对值”和“符号位”：

使用符号 IO 域来显示符号：

运行效果：


OMRON PLC 变量能读不能写

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > PLC通讯 > 与PLC通讯V2 >
OMRON PLC 变量能读不能写

问题：面板和 OMRON PLC通讯，为什么变量能读不能写？

解答：只有 OMRON PLC 处于“监视”状态才可以进行写操作


通过 EM277 连接 S7-200

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > PLC通讯 > 与PLC通讯V2 >
通过 EM277 连接 S7-200

问题：Smart Panels 能否通过 EM277 连接 S7-200？

解答：

SmartLine V1 及 V2 可以，配置文可以选择“PPI”、“MPI”、“DP”。

SmartLine V3，配置文可以选择“PPI”、“MPI”。

最远通讯距离 50 米，EM277 支持 5 个面板的连接。


通过 CP243-1 连接 S7-200

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > PLC通讯 > 与PLC通讯V2 >
通过 CP243-1 连接 S7-200

如何组态 WinCC flexible 运行系统或基于Windows 的面板和 S7-200 (CP 243-1) 控制器的以太网通讯?
http://support.automation.siemens.com/WW/view/zh/19724696

注意：要求 CP243-1 要紧靠 CPU 。


面板和 Micro/Win 同时连接 S7-200

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > PLC通讯 > 与PLC通讯V2 >
面板和 Micro/Win 同时连接 S7-200

问题: Smart 面板与 S7-200 进行串口通信时，是否可以使用同一个通讯口给 S7-200 下载程序（监视程序）？

解答：需要面板退出运行系统。


S7-200 字符串

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > PLC通讯 > 与PLC通讯V2 >
S7-200 字符串

问题：如何使用 Smart Panels 监控 S7-200 中的字符串变量？

解答：
在 PLC 中创建数据块：

Step7 Micro/win 中监视：

在 WinCC flexible 中创建 StringChar 类型的变量：

运行效果：

对“变量4”写操作：

Step7 Micro/win 中监视:


和 LOGO! 通信

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > PLC通讯 > 与PLC通讯V2 >
和 LOGO! 通信

Smartline-IE 可以和 LOGO! 0BA7 通讯。

LOGO! 中需要做以下设置：

1、在工具菜单下选择“Ethernet Connections”：

2、设置 IP 地址及连接：

3、选择“Server Connection”，其它配置如图：

具体请参考：

怎样建立 LOGO! 0BA7 和 HMI 触摸屏之间的连接？
http://support.automation.siemens.com/WW/view/en/56348902


画面刷新慢

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > PLC通讯 > 与PLC通讯V2 >
画面刷新慢

西门子的面板与PLC通信速度慢，其实很多情况下都是因为设置不当而导致的。如下列出了一些设置，都会影响到面板与PLC的通信速度。

1、变量的刷新周期
普通的通信方式，面板能支持的最小刷新周期是100ms。

是不是设置得越短，通信就越快呢？
当变量很少时，基本上是这样。但若变量很多时，则不然。因为大量的通信任务执行的时间远超刷新周期，将导致通信堵塞。表现就是通信速度反而会下降。所以应该根据项目的实际需要，变量刷新周期该长的长，该短的短。
对于某些特殊的应用，如直接键。则可以将面板组态为DP从站。从而保证某些关键数据的快速传送。

2、变量的采集模式
变量具有三种采集模式，循环连续，循环使用及根据命令。
默认情况下，我们应该将其设置为循环使用的方式。这表示只有当前画面中使用到了某变量，该变量才会被刷新，才会产生通信负荷。如果错误地设置为循环连续，那么不管当前画面中是否使用该变量，面板都会在后台不停地刷新该变量，从而产生不必要的通信负荷，降低了面板整体的通信速度。
设置为循环连续方式常见的应用是该变量组态了数值更改事件。

3、变量的地址连续性
变量的地址连续的话通讯效率比较高，这时需要发送的协议包相对比较少。

4、通信波特率
当然是越快越好，前提是线路质量好，干扰少或接地屏蔽等措施得当。当通信条件差时，高波特率导致通信失败几率更高，反而会降低成功通信的速度。如果此时将波特率降低，则会降低通信数据包出错的几率，从而改善通信速度。

5、单个画面中I/O域的数量
每款面板都会在性能参数中给出单个画面中最大允许组态的对象数量，如最多几个域，最多几个变量，最多几个复杂对象等。这都是极限参数。实际应用的项目不建议让这些参数达到极限值，除非项目比较简单，通信变量不多的情况。所以，如果可能，将多I/O域的画面拆分成子画面。


判断通信是否中断

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > PLC通讯 > 与PLC通讯V2 >
判断通信是否中断

问题：如何判断 Smart Panels 和 PLC 通讯是否正常？

解答：两种方法

1、通过画面上的 IO 域来判断，如果通讯中断，则相应的 PLC 变量显示为 ### :

2、系统报警

系统事件中有对应的通讯中断和通讯建立的报警，可以在画面中添加报警视图或在画面模版中添加报警窗口来显示这些报警。


通讯优化

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > PLC通讯 > 与PLC通讯V2 >
通讯优化

通讯优化的几个方面：

1、变量的采集模式
特殊应用变量（报警、曲线、触发数值更改事件）的采集模式设置为循环连续，其它变量的采集模式设置为循环使用。

2、变量的采集周期
当需要通讯的变量过多时，如果变量的采集速度过快（比如 100ms），则可能会发生通讯堵塞。这时就需要适当增大变量的采集周期。

3、变量的地址尽量连续
同一个画面中的变量地址尽可能连续，这样就需要 PLC 和 HMI 的程序统筹设计。

4、单个画面中对象的数量不要超限
具体限制可以从 WinCC flexible 软件帮助下的“性能限制”>“系统限制”一章中获得，相应面板的操作手册中也有系统限制的说明。

5、减少变量个数
如果画面中使用的 Bool 变量过多，可以创建字类型的变量，然后在画面中使用这个字类型变量的第几位即可。

6、通信波特率
条件允许的情况下尽量提高通讯波特率。


与 PLC 时钟同步

SIMATIC Panels 常见问题集 > SmartLine-IE V3 >
与 PLC 时钟同步

该章节包括以下主题的信息:

.概述

.S7-200

.Smart 200

.三菱

.欧姆龙


概述

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > 与 PLC 时钟同步 >
概述

SmartLine-IE V3 新增了硬件时钟功能，最长可缓冲6周。所以修改触摸屏系统时钟可通过两种方式。

1.使用 “日期时间域”修改时间。

将工具栏 “简单对象”中的 “日期时间域” 拖入画面。

修改 “日期时间域”属性中的 “类型” 改为 输入输出，将 “过程” 选为 “显示系统时间”,
然后在触摸屏项目下载后通过此 “日期时间域”修改时间即可。

2.使用 PLC 的时间来同步 Smart Panels 的时间，则需要使用“日期/时间 PLC”区域指针，并要在PLC中创建如下日期/时间数据区：


S7-200

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > 与 PLC 时钟同步 >
S7-200

1、在 S7-200 中，使用 READ_RTC 函数定时读取 CPU 的系统时间，将时钟信息放在 V 区，比如 VB100。

2、WinCC flexible 区域指针中配置“日期/时间 PLC”：

3、如果通讯正常，Smart Panels 的系统时间会和 S7-200 的时间保持一致。


Smart 200

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > 与 PLC 时钟同步 >
Smart 200

1、在 Smart200 中，使用 READ_RTC 函数定时读取 CPU 的系统时间，将时钟信息放在 V 区，比如 VB100 ：

2、WinCC flexible 区域指针中配置“日期/时间 PLC”：

3、如果通讯正常，Smart Panels 的系统时间会和 Smart200 的时间保持一致。


三菱

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > 与 PLC 时钟同步 >
三菱

1、在三菱编程软件 GX Developer 中使用 TRD 指令读取 CPU 时间，放到 D20 开始的地址区中（示例中使用的 D20，其它地址也可以）：

2、然后做如下处理：

3、WinCC flexible 区域指针中配置“日期/时间 PLC”：

4、如果通讯正常，Smart Panels 的系统时间会和 PLC 的时间保持一致。


欧姆龙

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > 与 PLC 时钟同步 >
欧姆龙

说明：OMRON CP1 PLC 中的时间存储在特殊寄存器 AR351--AR354 中：

1、为了满足时间同步要求的格式，需要在 PLC 中编程做如下处理：

处理结果：

2、WinCC flexible 区域指针中配置“日期/时间 PLC”：

3、如果通讯正常，Smart Panels 的系统时间会和 PLC 的时间保持一致。


画面

SIMATIC Panels 常见问题集 > SmartLine-IE V3 >
画面

该章节包括以下主题的信息:

.趋势视图 X 轴模式

.趋势视图线类型

.趋势视图显示范围

.闪烁动画

.PLC 控制画面显示

.弹出式对话框

.点动按钮

.透明色

.旋转对象

.横屏及竖屏组态


趋势视图 X 轴模式

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > 画面 >
趋势视图 X 轴模式

SmartLine-IE V3 的趋势视图只能显示实时曲线。

趋势视图中的实时曲线是一直刷新的，Y 轴固定是数值轴，X 轴显示模式可以设置为“时间”、“点”、“常量”：

“时间”：X 轴显示的是时间，时间间隔决定曲线的时间范围

运行效果：

“点”：X 轴以采集点的模式显示，点数决定曲线的长度

运行效果：

“常量”：和类型“点”类似，区别是 X 轴开端和末端的值可以设定

运行效果：


趋势视图线类型

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > 画面 >
趋势视图线类型

趋势视图中曲线可以以“线”、“点”、“步进”、“棒图”四种形式显示：

“线”类型：

“点”类型：

“步进”类型：

“棒图”类型：


趋势视图显示范围

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > 画面 >
趋势视图显示范围

趋势视图中选择实时变量时，需要同时设定采集周期（脉冲）：

能显示的时间长度 = 采样点数 * 脉冲，上图中为 999 * 1s = 999s ，同时需要把时间间隔改成 999s ：

这样趋势曲线的显示范围才能达到 999s 。


闪烁动画

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > 画面 >
闪烁动画

问题：如何为对象做颜色闪烁动画？

解答：在对象外观动画下使能“闪烁”后，当条件满足（下图中变量“tag_1”的第1位被置位）时，对象就会闪烁（前景色和背景色之间切换）。


PLC 控制画面显示

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > 画面 >
PLC 控制画面显示

WinCC flexible Smart V3 每个画面都有唯一的编号：

创建外部变量“tag1”（地址 MW0，采集模式“循环连续”），在其“更改数值”事件下使用函数 ActivateScreenByNumber ( "tag1" , 0 )。

PLC 中给 MW0 赋值，即可切换到相应的画面。

具体步骤请参考：
http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=845


弹出式对话框

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > 画面 >
弹出式对话框

问题：如何在 WinCC flexible Smart V3 中实现弹出窗口及输入数值的确认？

分析：在 WinCC flexible Smart V3 中，不支持弹出窗口。可以通过对象的显示/隐藏变相地实现弹出效果。WCF 没有提供 IO 域的输入确认。可以通过指针变量及弹出窗口来实现。

具体实现：如下示例的功能是当单击 “IO 域_4” 试图为 “变量_2” 输入数值时，将弹出提示框。单击 “确定” 后，将把输入值写入 “变量_2”；单击取消，则不改变 “变量_2” 的原值。同时在弹出提示框后，画面其它对象都不允许操作。模仿模式窗口的效果。另外，当单击“按钮_3” 时，也加入了确认的提示。

1、 新建如下变量：

2、变量 valueIN “指针化”，属性设置如右图所示：

3、在画面第 1 层添加一个矩形对象，大小与画面一样。“外观” 属性设置如下：

4、“可见性” 设置如下：

5、在画面的第 1 层放置如下对象，作为提示对话框。
其中 “确定” 按钮是重叠在一起的两个按钮。一个用来确认 “IO 域_4”的输入操作，另外一个用来确认“按钮_3” 的操作。

所有对象都启用 “可见性”。为其中一个 “确定” 按钮分配变量 dis1，另一个确定按钮分配变量 dis2，其它所有对象都分配 dis，设置如下：

6、为 “取消” 按钮增加单击事件函数：

7、为 “可见性” 关联 dis1 变量的 “确定” 按钮增加如下单击事件函数：

8、为 “可见性” 关联 dis2 变量的 “确定” 按钮增加如下单击事件函数：

9、为 “IO 域_4” 增加激活事件函数：

10、为 “按钮_3” 增加单击事件函数：

11、运行效果
当单击 “IO 域_4”时，弹出如右图所示的提示：

在输入框中输入数值 99，并单击回车后，提示如下：

除了 “确定” 和 “取消” 按钮之外的所有画面对象都不能操作。
此时如果单击 “确定” 按钮，数值 99 将赋值给 “变量_2” ；单击“取消”则 “变量_2” 保持原值。
单击 “按钮_3” ，提示如下：

除了 “确定” 和 “取消” 按钮之外的所有画面对象都不能操作。
此时如果单击 “确定” 按钮，将执行 “趋势” 按钮的功能，切换到 “趋势” 画面。单击 “取消” 则没有任何改变。


点动按钮

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > 画面 >
点动按钮

关于按钮点动操作的实现方法

常规做法是按钮按下时置位变量（Setbit）释放时复位变量（Resetbit）

注意：上面的方法，当操作过快时可能会出现数据丢失的现象（无法置位或置位后无法复位变量）。为了操作可靠，建议 HMI 只置位变量，PLC 接收信号并处理后，再复位此变量 。


透明色

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > 画面 >
透明色

SmartLine-IE V3 的 “图形视图” 及 “图形 IO 域” 开始支持透明色功能。

1.将工具栏中增强对象中的 “图形视图” 或 “图形 IO 域”拖入到画面中。

2.在 “图形视图” 对象或 “图形 IO 域”对象的 “属性“ --“外观” 中
勾选 “透明色” 选项，并选择需要透明的颜色，本例中图片的背景色为白色，
选中白色后，白色变为透明。

3.实际效果。右侧 “图形视图” 对象为激活了透明色选项的效果。


旋转对象

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > 画面 >
旋转对象

SmartLine-IE V3 新增了在组态界面下旋转对象的功能。

以下对象支持组态时旋转：
图形视图、图形 IO 域、按钮、开关、椭圆、矩形、静态文本、棒图。

操作步骤如下：

1.在画面中添加一个按钮。

2.选中该按钮后点击工具栏中的 “旋转工具”菜单中的“向右90度”按钮。

3.旋转结果。


横屏及竖屏组态

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > 画面 >
横屏及竖屏组态

SmartLine-IE V3 支持水平或垂直方式安装，那么在项目组态时需进行选择，操作步骤如下：

1.组态水平安装方式触摸屏项目。

2.组态垂直安装方式触摸屏项目。

3.将项目下载到屏中以后，屏会自动根据触摸屏项目中水平或垂直的项目模式自动进行切换，用户无需手动在屏上进行设置。


报警

SIMATIC Panels 常见问题集 > SmartLine-IE V3 >
报警

该章节包括以下主题的信息:

.高低字节

.报警类别


高低字节

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > 报警 >
高低字节

问题：创建如下的变量和离散量报警，触发器位和触发器地址是什么样的对应关系？

解答：

在组态离散量报警时，需要注意 SIEMENS PLC 的高低字节是反着的，如下图：

具体请参考：

离散量报警触发位(高八位与低八位的关系)
http://www.ad.siemens.com.cn/service/elearning/cn/Course.aspx?CourseID=902


报警类别

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > 报警 >
报警类别

1、在报警类别中可以定义各种状态报警的显示颜色。

2、如果要使用在报警类别中定义的颜色，还需要在报警设置中选择“使用报警类别颜色”。


记录

SIMATIC Panels 常见问题集 > SmartLine-IE V3 >
记录

该章节包括以下主题的信息:

.报警记录

.数据记录


报警记录

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > 记录 >
报警记录

SmartLine-IE V3 新增了 USB 2.0 接口，如果外接 USB记忆棒，则可以用来记录报警记录。

注意：1.在当前版本，报警记录仅可记录在USB记忆棒中，不可在屏上显示。
2.仅可建立1个归档文件，该文件的最大可记录条数为10000条。
3.记录文件名及路径 仅支持英文 ，并且记录文件的格式仅可选择 “TXT”。
4.路径必须选择 “\USB_X60.1”。

1.在项目左侧的项目树中选择 “历史数据” 中的 “报警记录”并双击打开。

2.在 “报警记录” 中建立新的报警记录。

3.在项目左侧的项目树中选择 “报警管理”中 “设置”中的 “报警类别”。

4.在 “报警类别” 中配置所需记录类别的 “报警记录”文件。

5.最终文件会以 TXT 的格式保存在 USB 2.0 记忆棒的相应路径中。可以在屏断电或项目未运行的情
况下将USB记忆棒拔出并接入到计算机中查看数据。


数据记录

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > 记录 >
数据记录

SmartLine-IE V3 新增了 USB 2.0 接口，如果外接 USB记忆棒，则可以用来记录数据记录。

注意：1.在当前版本，数据记录仅可记录在USB记忆棒中，不可在屏上显示。
2.仅可建立1个归档文件，该文件的最大可记录条数为10000条，仅可配置5个变量。
3.记录文件名及路径仅支持英文 ，并且记录文件的格式仅可选择 “TXT”。
4.路径必须选择 “\USB_X60.1”。

1.在项目树中的 “历史数据” 中选择 “数据记录” 并双击打开。

2.在 “数据记录“ 中新建一条数据记录。

3.在项目树中的 “通讯” 中选择 “变量” 并双击打开。

4.在需要记录的变量的属性中，选择 “记录” 并将已建好的数据记录文件配置在 “数据记录” 处。

5.最终文件会以 TXT 的格式保存在 USB 2.0 记忆棒的相应路径中。可以在屏断电或项目未运行的情
况下将USB记忆棒拔出并接入到计算机中查看数据。


用户管理（安全）

SIMATIC Panels 常见问题集 > SmartLine-IE V3 >
用户管理（安全）

该章节包括以下主题的信息:

.用户突然“失效”


用户突然“失效”

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > 用户管理（安全） >
用户突然“失效”

问题：原来面板中的用户可以正常登录，用户登录后也可以正常操作，但这个用户突然会“失效”？

解答：这是由于操作人员对这个用户连续输错三次密码造成的，这个和项目中设置的“无效登录尝试次数”有关。

默认无效登录尝试次数为 3 次（不使能“口令时效”时“无效登录尝试次数”也是起作用的），把它设为 0 即可取消这个限制。

下面来看一下产生这个问题的过程：

1、一个用户原来是属于某个实际组的：

2、对这个用户连续输错三次密码后，这个用户会被归到“未授权”组，没有任何权限：

出现问题后的解决方法

解决方法一：用管理员登录，在用户视图中修改用户所属的组。

解决方法二：

1、用 Prosave 将该屏做一个完整备份；
2、用 WinCC flexible Smart V3 新建一个空项目，其它组态无所谓，重要的是创建原来屏上已组态的所有用户并分配密码，然后将该程序下载到屏中；
3、用 Prosave 备份屏中的用户管理；
4、恢复 1 中所做的备份到屏中；
5、恢复 3 中所做的用户管理到屏中。

（若客户有源程序，那么可以省略 1、4 步的操作）


多语言项目

SIMATIC Panels 常见问题集 > SmartLine-IE V3 >
多语言项目

该章节包括以下主题的信息:

.创建多语言项目


创建多语言项目

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > 多语言项目 >
创建多语言项目

WinCC Flexible Smart V3 已发布的项目语言如下：

注意：项目语言“Irish（Ireland）”当导致编译故障。请不要使用此语言作为运行时的项目语言。

那么如何组态多语言项目及切换项目语言？

请参考：
http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=655
http://www.ad.siemens.com.cn/service/elearning/cn/CourseV2.aspx?CourseID=656


面板设置

SIMATIC Panels 常见问题集 > SmartLine-IE V3 >
面板设置

该章节包括以下主题的信息:

.触摸校准


触摸校准

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > 面板设置 >
触摸校准

当面板触摸不准时就需要做触摸校准，具体操作步骤如下：

1.点击 “Control Panel” 按钮。

2.双击 “OP” 选项。

3.选择 “Touch” 选项卡，并点击 “Recalibrate” 按钮，进入校准界面。

4.在进入校准界面后的 15秒 内需点击触摸屏开启校准模式，否则会自动退出校准界面。

5.依次点击十字准心进行校准。

6.看到如下提示，等待系统自动退出校准界面，校准完成。


其他常规信息

SIMATIC Panels 常见问题集 > SmartLine-IE V3 >
其他常规信息

该章节包括以下主题的信息:

.重置软件

.Prosave中看不到SmartLine


重置软件

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > 其他常规信息 >
重置软件

WinCC Flexible Smart V3 软件安装后不再在 Windows 任务栏处添加 “WinCC Flexible 启动中心”图标。

老版本软件异常时可通过该图标中的 “重置 SIMATIC WinCC flexible（R）”选项重置软件到默认安装状态。

在 WinCC Flexible Smart V3 中可按如下操作

Win7 SP1 32位系统重置:
. 32 位系统重置

Win7 sp1 64位系统重置：
. 64 位系统重置


Prosave中看不到SmartLine

SIMATIC Panels 常见问题集 > SmartLine-IE V3 > 其他常规信息 >
Prosave中看不到SmartLine

问题：在 Simatic Prosave 软件中无法找到 SmartLine 系列触摸屏。

解决方法：将 Simatic Prosave 软件的界面语言改为 “简体中文” 即可。

1.可以看到在英文界面语言下，仅能看到 “SmartLine Panels” 系列，但无法看到触摸屏。

2.将界面语言改为 “简体中文”。

3.更改界面语言后，正常显示。